Accueil Forum -> Site -> Réclamation  >>  Avis de recherche : menu disparu…
9 messages
Accueil Forum -> Site -> Réclamation  >>  Avis de recherche : menu disparu…
9 messages

Avis de recherche : menu disparu…

07 juin 2018 à 22:32 MetalTux    
Le menu de notification a récemment disparu dans la version mobile du site

Image

Image

Avis de recherche : menu disparu…

07 juin 2018 à 23:01 Admin      
Étrange.... Je regarde ça dès demain

Avis de recherche : menu disparu…

08 juin 2018 à 13:28 Admin      
J'ai testé et tout fonctionne du coup je seche un peu là x) 

Tu a bien la barre quand tu es sur ordi ? tu as testé de déco reco ?

Avis de recherche : menu disparu…

08 juin 2018 à 16:29 MetalTux    
La recinnexion n'y change rien.

Le menu apparait parfois brièvement lors du chargement de la page puis redisparait aussi tôt… bizarre.

Et il y a 2-3 jours, le menu était encore là, bizarre aussi…

Je retesterai sur desktop ce soir

Avis de recherche : menu disparu…

09 juin 2018 à 00:44 roodaal      
aucun souci pour ma par

Avis de recherche : menu disparu…

09 juin 2018 à 16:35 MetalTux    
@admin

Sur desktop j'ai le menu. Sur mobile toujours parait : Il apparaît rapidement au premier chargement de la page puis disparaît avant la fin de chargement…

Image

Je sais pourquoi t'arrive pas à reproduire le bug, on fait pas le test dans les mêmes conditions. Le rendu varie en fonction des caractéristiques de l'écran et devient foireux dans certains cas, pas dans d'autres.

J'ai pas analysé le CSS, et je suis pas dev web mais j'ai bien une idée sur le sujet, même si j'ai pas la solution

Étant donné que si je force la version desktop sur mobile (1), j'ai pas non plus le menu de gauche qui s'affiche. Et que avec le Responsive Design mode des outils de dev de Firefox, avec des profils les appareils de type tablettes (test avec plusieurs) me donne le même comportement, pas de menu de notifs tout à gauche (2) ni ailleurs. Même constat pour les profils de PS Vita et Wii U Gamepad ou encore un laptop 1280x720 avec un Device Pixel Ratio de 1.5. Dans tous cas le menu de gauche n'apparaît pas à 100% de zoom, mais apparaît si on dézoome. Sauf que sur un vrai appareil mobile, dézoomer n'est ni pratique (écran trop petit) ni même possible, dans la plupart des cas.

Donc ma théorie est qu'au delà d'une certaine définition d'écran (ou du moins largeur) il tente un affichage comme sur desktop suite a modification récente, sauf que si l'écran n'est pas assez large ou n'a pas le « bon » rapport (quelque de correctement supporté par le code/framework/ce qu'on veut), et comme il y a jamais de barre de scroll horizontale qui s'affiche en vrai (en dehors des outils de debug) pour une raison que j'ignore, il échoue à afficher le menu de gauche correctement parce que pas de place. Il ne l'affiche pas ailleurs non plus. D'où le comportement sur les écrans de tablettes ou de consoles portables, ou encore d'un laptop avec une résolution à la con.

Dans le cas de mon tel, même si c'est pas un affichage à la desktop (2ème menu horizontal vs menu déroulant), il se plante quand même pour afficher le menu, comme sur tablettes… je serai pas étonné que le même bug/la même cause

Par contre ça explique pas pourquoi le bouton du menu en question s'affiche rapidement et disparaît au 1er chargement d'une page (premier après chaque lancement du navigateur, c'est pas une histoire de cache) donc il doit y avoir autre chose

Je constate aussi si je zoom un peu (130%) sur desktop, au lieu d'avoir une barre de scroll horizontale qui apparaît ou le menu qui se déplace là où il y a de l'espace (genre en haut ou en bas) , le menu de gauche disparaît complètement (pas juste caché par zoom)

1. Affichage desktop sur le tel, en mode portrait et en mode paysage
Image
Image

2. Affichage avec une définition d'écran et un DPR de tablette (J'ai testé avec presque tous les profils de tablette dispo dans la liste. Du pareil au même)
Image
C'est la totalité de la largeur qui est affichée, avec zoom à 100% (normal). La barre de scroll horizontale qui s'affiche en mode debug sert a rien pour cette résolution » (Elle bute des deux cotés)

Avis de recherche : menu disparu…

18 juillet 2018 à 17:29 MetalTux    
Salut

J'ai toujours pas de nouvelles sur ce bug

Avis de recherche : menu disparu…

30 août 2018 à 18:14 MetalTux    
Le bug est toujours toujours présent… Il doit bien y avoir une raison qui explique pourquoi le bouton. ocial n'apparaît qu'une fois sur trouzemilles…

Avis de recherche : menu disparu…

24 novembre 2018 à 11:32 MetalTux    
Bug toujours pas corrigé…